Создание формы подбора для документа



В данной статье речь пойдет о создании формы подбора Номенклатуры, открываемой из формы документа для подбора необходимых позиций. Форма будет создана на основе общих форм и будет состоять из трех списков. Первый список будет отображать дерево значений номенклатуры, второй - непосредственно список номенклатуры, а в третьем будут отображаться выбранные значения. Для начала зайдем в документ, создадим кнопку "Подбор" и команду на кнопку. Теперь добавим действие на эту команду в котором пропишем код, открывающий форму подбора: &НаКлиенте
Процедура Подбор(Команда)
ОткрытьФорму("ОбщаяФорма. ФормаПодбора");
КонецПроцедуры
Далее закрываем форму документа (к ней мы вернемся чуть позже) и создаем новую общую форму "ФормаПодбора":

Далее добавляем таблицу на форму и реквизит к таблице. Тип данных реквизита будет "ДинамическийСписок". В свойствах реквизита в разделе Объект поставим галочку - "Произвольный запрос" и нажмем на ссылку Настройка списка: В появившейся форме нам необходимо будет написать запрос который будет отображаться в таблице "Дерево". Текст запроса будет выглядеть так: ВЫБРАТЬ
Номенклатура. Наименование КАК Группа
ИЗ
Справочник. Номенклатура КАК Номенклатура
ГДЕ
Номенклатура. ЭтоГруппа Теперь нужно немного изменить настройки для таблицы Дерево, точнее изменить кое какие свойства отображения нашего древовидного списка: 1. Установим галочку на свойство ТолькоПросмотр 2. Установим галочку на свойство РежимВыбора 3. ПоложениеКоманднойПанели - Нет 4. Отображение - Дерево 5. Режим выделения - Одиночный 6. Начальное отображение дерева - Раскрывать верхний уровень 7. Выбор групп и элементов - Группы 8. РазрешитьВыборКорня - Галочка Посмотрим что у нас получилось:

Неплохо. Следующим шагом будет создание таблицы где будет отображаться сама номенклатура. Создадим на форме еще отдну таблицу Список и добавим реквизит с таким же названием. Как и в случае с реквизитом Дерево повторяем те же манипуляции, т. е. тип - ДинамическийСписок, произвольный запрос - Да. Открываем форму редактирования запроса. Тут придется написать запрос чуточку сложнее (подробности можно посмотреть в конструкторе запросов): ВЫБРАТЬ
ЦеныСрезПоследних. Цена,
НоменклатураСписок. Код,
НоменклатураСписок. Ссылка
ИЗ
Справочник. Номенклатура КАК НоменклатураСписок
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений. Цены. СрезПоследних КАК ЦеныСрезПоследних
ПО НоменклатураСписок. Ссылка = ЦеныСрезПоследних. Номенклатура. Ссылка
ГДЕ
НоменклатураСписок. Родитель. Ссылка В(&Группа)
СГРУППИРОВАТЬ ПО
ЦеныСрезПоследних. Цена,
НоменклатураСписок. Код,
НоменклатураСписок. Ссылка Плюс нужно создать событие формы ПриСозданииНаСервере и прописать в нем наш фильтр "Группа": &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Список. Параметры. УстановитьЗначениеПараметра("Группа", Группа);
КонецПроцедуры Форма почти готова. Осталось связать наши таблицы: Дерево и Список. Для этого нужно будет создать еще несколько событий для таблицы Дерево: &НаКлиенте
Процедура ОбновитьСписок()
Список. Параметры. УстановитьЗначениеПараметра("Группа", Группа);
КонецПроцедуры

&НаКлиенте
Процедура ДеревоВыборЗначения(Элемент, Значение, СтандартнаяОбработка)
Группа = Значение;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
Группа = ВыбранноеЗначение;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоПередРазворачиванием(Элемент, Строка, Отказ)
Группа = Строка;
ОбновитьСписок();
КонецПроцедуры &НаКлиенте
Процедура ДеревоПередСворачиванием(Элемент, Строка, Отказ)
Группа = Строка;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоПриСменеТекущегоРодителя(Элемент)
Группа = Элемент. Родитель;
ОбновитьСписок();
КонецПроцедуры Наша форма почти готова: Ну и наконец добавим третий список (тип данных - ТаблицаЗначений), в который добавим 2 колонки - Номенклатура и Цена: а в таблице "Список" добавим событие "Выбор": &НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)

ТекущаяСтрока = Элемент. ТекущиеДанные;
НоваяСтрока = Отобранные. Добавить();
НоваяСтрока. Номенклатура = ТекущаяСтрока. Ссылка;
НоваяСтрока. Цена = ТекущаяСтрока. Цена;

КонецПроцедуры Теперь необходимо чтобы эта форма возвращала отобранные значения, обратно в форму документа. Для этого создадим новую кнопку "ОК" и создадим новую команду с таким же названием. Событие будет выглядеть так: &НаКлиенте
Процедура ОК(Команда)
Закрыть(ЗаписатьВХранилище());
КонецПроцедуры
а функция ЗаписатьВХранилище будет такая: &НаСервере
Функция ЗаписатьВХранилище()
Возврат ПоместитьВоВременноеХранилище(Отобранные. Выгрузить());
КонецФункции
Откроем опять форму нашего документа и исправим процедуру Подбор, добавив процедуру получения данных из временного хранилища: &НаСервере
Процедура ПолучитьЗапасыИзХранилища(АдресВХранилище)

ВременнаяТаблица = ПолучитьИзВременногоХранилища(АдресВХранилище);

Для Каждого ЗагружаемаяСтрока Из ВременнаяТаблица Цикл
СтрокаТЧ = Объект["Товар"]. Добавить();
СтрокаТЧ. Номенклатура = ЗагружаемаяСтрока. Номенклатура;
СтрокаТЧ. Цена = ЗагружаемаяСтрока. Цена;
КонецЦикла;

КонецПроцедуры
&НаКлиенте
Процедура Подбор(Команда)

ФормаПодбора = ПолучитьФорму("ОбщаяФорма. ФормаПодбора");
АдресВХранилище = ФормаПодбора. ОткрытьМодально();
Если ЗначениеЗаполнено(АдресВХранилище) Тогда
ПолучитьЗапасыИзХранилища(АдресВХранилище);
КонецЕсли;

КонецПроцедуры Наконец наша форма подбора готова: Источник материала
23:35 24.03.2017



Отзывы и комментарии
Ваше имя (псевдоним):
Проверка на спам:

Введите символы с картинки:



Стоит ли верить методам определения пола будущего ребенка?

Стоит ли верить методам определения пола будущего ре...

Едва вы узнали, что беременны, и вот у вас уже масса планов, задумок, вопросов. И, чего уж тут лукавить, один из первых — кто же родится: мальчик или девочка? Причем не только впечатли...
Как решить проблему вентиляции при выборе пластикового окна? Советы архитектора

Как решить проблему вентиляции при выборе пластиково...

Пластиковые окна в силу своей герметичности отлично защитят вашу квартиру от летней жары и зимних холодов, уличного шума, пыли, тополиного пуха, назойливых насекомых, выхлопных газов и… свежего...
Вкусные рецепты: Падзаропита., Салат"Румянец", ВЕСЕЛО,ВЕСЕЛО ВСТРЕТИМ НОВЫЙ ГОД!

Вкусные рецепты: Падзаропита., Салат"Румянец&qu...

Падзаропита.ТЕСТО: В глубокой миске смешать просеянную муку, соль и тимьян. Добавить уксус. Замесить тесто, постепенно подливая воду и масло. Месить около 8 минут, до получения мягкого эластичного тес...
Гидравлические расчеты инженерных сетей как объектов геоинформационных систем

Гидравлические расчеты инженерных сетей как объектов...

А.Р.Ексаев, В.А.Вайсфельд (ИВЦ "Поток") 1998 г. (переиздание 2007 г.) Авторы продолжают серию статей (см. ИБ ГИС No 1(8), 3(10), 5(12) за 1997 г.), посвященных применению геоинформационных технологий ...
У любимой день рождения? Нестандартные советы для неленивых мужчин.

У любимой день рождения? Нестандартные советы для не...

Если ты — убежденный женоненавистник, гей или законченный жмот, можешь дальше не читать, противный. Эта статья для настоящих мужчин. Для тех, кого приводят в трепет женские ножки, ручки и п...
Сон

Сон

Англия, 19 век. Широкая пустынная улица, серое небо. Я иду на работу. Прохожу мимо домов, которые заперты и вижу, что двери огромнейшего особняка распахнуты. Захожу внутрь, там царит полумрак и я пон...
Читаемые

Что поможет усталым глазам? Гимнастика

«Глаза — зеркало души» Только если в отражении вы видите их уставшими и покр...

Как сэкономить на прическе? Шампуни и бальзамы

Считается, что из ничего женщина всегда сможет сделать три вещи: истерику, салатик и прическу. Однак...

Трубопроводная арматура: термины

Под термином "трубопроводная арматура" понимают устройство, устанавливаемое на трубопроводах, агрега...

Как сегодня обувают лохов? Часть 2

Продолжаем повествование о современных грамотных лохотронщиках. …Крутой Мэн рассказал о прин...

Что понимается под удобством апартаментов, арендов

Все мы любим пользоваться различными преимуществами цивилизации и поэтому вправе рассчитывать на вес...

От работы кони дохнут. Чем зарабатывать на жизнь?

О труде стахановском, или Как превратиться в негра-невольника. С каждым годом все меньше становится...

Интерьер современной гостиной

Гостиная в современном понимании – это не просто центральная часть квартиры, но и место, где могут б...

Аудит. Правильная отчетность предприятия.

Теперешняя экономическая ситуация требует от всех без исключения фирм крайне внимательного подхода к...

Вкусные рецепты: Очень сырная запеканка, супчик- б

Очень сырная запеканкаНагреть духовку до 200*С. Отварить овощи до полуготовности, чтоб тожно было ле...

Серийные убийцы и маньяки в кино - кто они?

Реальность кусается. В жизни случаются крайне бесчеловечные поступки, а изворотливость, хитрость, ко...



Новости развития информационнного портала:

Наш портал является ресурсом, который включает в себя широкий список информативных и отличных статей. Абсолютно каждый гость найдет для себя что-нибудь полезное. Модернизированный дизайн позволяет вам быстро находить требуемую информацию. Самые разнообразные тематические статьи дают возможность вам совершенствоваться в той или иной сфере. Быть более начитанным и грамотным. Современный дизайн сайта позволяет просматривать статьи на всех существующих планшетах. Теперь найти подходящую информацию стало совершенно легко.

Мы собрали для вас информативные и отличные статьи. На нашем портале вы найдете ответы на интересующие вас вопросы. Стандартная система поиска позволяет вам стремительно отыскать нужную информацию. Адаптированный дизайн позволяет вам просматривать информацию на абсолютно любых электронных устройствах. Теперь, поиск необходимой информации будет занимать у вас секунды.