Создание формы подбора для документа



В данной статье речь пойдет о создании формы подбора Номенклатуры, открываемой из формы документа для подбора необходимых позиций. Форма будет создана на основе общих форм и будет состоять из трех списков. Первый список будет отображать дерево значений номенклатуры, второй - непосредственно список номенклатуры, а в третьем будут отображаться выбранные значения. Для начала зайдем в документ, создадим кнопку "Подбор" и команду на кнопку. Теперь добавим действие на эту команду в котором пропишем код, открывающий форму подбора: &НаКлиенте
Процедура Подбор(Команда)
ОткрытьФорму("ОбщаяФорма. ФормаПодбора");
КонецПроцедуры
Далее закрываем форму документа (к ней мы вернемся чуть позже) и создаем новую общую форму "ФормаПодбора":

Далее добавляем таблицу на форму и реквизит к таблице. Тип данных реквизита будет "ДинамическийСписок". В свойствах реквизита в разделе Объект поставим галочку - "Произвольный запрос" и нажмем на ссылку Настройка списка: В появившейся форме нам необходимо будет написать запрос который будет отображаться в таблице "Дерево". Текст запроса будет выглядеть так: ВЫБРАТЬ
Номенклатура. Наименование КАК Группа
ИЗ
Справочник. Номенклатура КАК Номенклатура
ГДЕ
Номенклатура. ЭтоГруппа Теперь нужно немного изменить настройки для таблицы Дерево, точнее изменить кое какие свойства отображения нашего древовидного списка: 1. Установим галочку на свойство ТолькоПросмотр 2. Установим галочку на свойство РежимВыбора 3. ПоложениеКоманднойПанели - Нет 4. Отображение - Дерево 5. Режим выделения - Одиночный 6. Начальное отображение дерева - Раскрывать верхний уровень 7. Выбор групп и элементов - Группы 8. РазрешитьВыборКорня - Галочка Посмотрим что у нас получилось:

Неплохо. Следующим шагом будет создание таблицы где будет отображаться сама номенклатура. Создадим на форме еще отдну таблицу Список и добавим реквизит с таким же названием. Как и в случае с реквизитом Дерево повторяем те же манипуляции, т. е. тип - ДинамическийСписок, произвольный запрос - Да. Открываем форму редактирования запроса. Тут придется написать запрос чуточку сложнее (подробности можно посмотреть в конструкторе запросов): ВЫБРАТЬ
ЦеныСрезПоследних. Цена,
НоменклатураСписок. Код,
НоменклатураСписок. Ссылка
ИЗ
Справочник. Номенклатура КАК НоменклатураСписок
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений. Цены. СрезПоследних КАК ЦеныСрезПоследних
ПО НоменклатураСписок. Ссылка = ЦеныСрезПоследних. Номенклатура. Ссылка
ГДЕ
НоменклатураСписок. Родитель. Ссылка В(&Группа)
СГРУППИРОВАТЬ ПО
ЦеныСрезПоследних. Цена,
НоменклатураСписок. Код,
НоменклатураСписок. Ссылка Плюс нужно создать событие формы ПриСозданииНаСервере и прописать в нем наш фильтр "Группа": &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Список. Параметры. УстановитьЗначениеПараметра("Группа", Группа);
КонецПроцедуры Форма почти готова. Осталось связать наши таблицы: Дерево и Список. Для этого нужно будет создать еще несколько событий для таблицы Дерево: &НаКлиенте
Процедура ОбновитьСписок()
Список. Параметры. УстановитьЗначениеПараметра("Группа", Группа);
КонецПроцедуры

&НаКлиенте
Процедура ДеревоВыборЗначения(Элемент, Значение, СтандартнаяОбработка)
Группа = Значение;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
Группа = ВыбранноеЗначение;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоПередРазворачиванием(Элемент, Строка, Отказ)
Группа = Строка;
ОбновитьСписок();
КонецПроцедуры &НаКлиенте
Процедура ДеревоПередСворачиванием(Элемент, Строка, Отказ)
Группа = Строка;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоПриСменеТекущегоРодителя(Элемент)
Группа = Элемент. Родитель;
ОбновитьСписок();
КонецПроцедуры Наша форма почти готова: Ну и наконец добавим третий список (тип данных - ТаблицаЗначений), в который добавим 2 колонки - Номенклатура и Цена: а в таблице "Список" добавим событие "Выбор": &НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)

ТекущаяСтрока = Элемент. ТекущиеДанные;
НоваяСтрока = Отобранные. Добавить();
НоваяСтрока. Номенклатура = ТекущаяСтрока. Ссылка;
НоваяСтрока. Цена = ТекущаяСтрока. Цена;

КонецПроцедуры Теперь необходимо чтобы эта форма возвращала отобранные значения, обратно в форму документа. Для этого создадим новую кнопку "ОК" и создадим новую команду с таким же названием. Событие будет выглядеть так: &НаКлиенте
Процедура ОК(Команда)
Закрыть(ЗаписатьВХранилище());
КонецПроцедуры
а функция ЗаписатьВХранилище будет такая: &НаСервере
Функция ЗаписатьВХранилище()
Возврат ПоместитьВоВременноеХранилище(Отобранные. Выгрузить());
КонецФункции
Откроем опять форму нашего документа и исправим процедуру Подбор, добавив процедуру получения данных из временного хранилища: &НаСервере
Процедура ПолучитьЗапасыИзХранилища(АдресВХранилище)

ВременнаяТаблица = ПолучитьИзВременногоХранилища(АдресВХранилище);

Для Каждого ЗагружаемаяСтрока Из ВременнаяТаблица Цикл
СтрокаТЧ = Объект["Товар"]. Добавить();
СтрокаТЧ. Номенклатура = ЗагружаемаяСтрока. Номенклатура;
СтрокаТЧ. Цена = ЗагружаемаяСтрока. Цена;
КонецЦикла;

КонецПроцедуры
&НаКлиенте
Процедура Подбор(Команда)

ФормаПодбора = ПолучитьФорму("ОбщаяФорма. ФормаПодбора");
АдресВХранилище = ФормаПодбора. ОткрытьМодально();
Если ЗначениеЗаполнено(АдресВХранилище) Тогда
ПолучитьЗапасыИзХранилища(АдресВХранилище);
КонецЕсли;

КонецПроцедуры Наконец наша форма подбора готова: Источник материала
23:35 24.03.2017



Отзывы и комментарии
Ваше имя (псевдоним):
Проверка на спам:

Введите символы с картинки:



Сезон простуды

Сезон простуды

Физиотерапия в борьбе с простудными заболеваниями Профилактика – лучшее средство Как бы ни была сильна простуда, не надо воспринимать ее как неизбежность и обреченно готовиться страдать от насморка,...
В каталоге Layta появилась компания NSGate!

В каталоге Layta появилась компания NSGate!

Предприятие NSGate заняло свое почетное место в каталоге магазина Layta. Данный производитель занимается выпуском и продажей высококачественных комплектующих для рынка IP-сетей. О NSGate Предприятие...
Как хозяйке обхитрить кризис? Хитрим с уксусом. Часть третья, огородная

Как хозяйке обхитрить кризис? Хитрим с уксусом. Част...

На дворе лето, и вот потянулись мы все на воздух. Кто поработать до ломоты спины, кто отдохнуть. А время сейчас как раз комарам роиться и все лето кусаться в свое удовольствие. Что делаем? Наливаем чи...
Вечерние платья в Харькове

Вечерние платья в Харькове

Все самое существенное в одежде выбирает сам человек: выбрать ткань и покрой, подбирает ансамбль. Так же не стоит забывать и о качественном белье, влияющем на линии фигуры, стильной прическе, обуви - ...
Отпуск в Алуште: каким образом провести идеальный отпуск

Отпуск в Алуште: каким образом провести идеальный от...

Если вы хотите провести отдых в Алуште, вам нужно заблаговременно подумать о том, где вы сможете остановиться. Прекрасный крымский городок Алушта не одно десятилетие привлекает к себе внимание турист...
Вегетарианство: каких оно бывает видов?

Вегетарианство: каких оно бывает видов?

Одно время я совсем не ела мяса. И ничуть об этом не жалею, чего бы вам ни пришлось услышать дальше из моих уст. Мало того, вегетарианство очень даже полезно. В малых дозах. Поэтому, если вам вдр...
Стоит прочесть

Наводнения в Венеции: aqua alta

Вся жизнь Венеции с момента ее основания подчинена диктату моря. Еще первые поселенцы, бежавшие сюда...

Кокшетау - экоотдых в Казахстане

Экоотдых Кокшетау находится к северу от Астаны. и 3 села - Имантау, Айыртау и Сандыктау, добраться ...

Отдых и лечение в Израиле

Самое необычное и уникальное море на Земле – Мертвое – славится своими целебными свойствами. Туристы...

Маркировка судовых дизелей

 В марках буквы дизелей обозначают: Д — двухтактный, Ч — четырехтактный, Р - реверсивный, С — с...

История проекта - Портфельные инвестиции, Москва

ЗАДАЧА Перепланировка старинных зданий под современные офисы требует, порой, немалых инженерных и т...

Как повлияет изобретение искусственного интеллекта

Существует достаточно много мнений учёных относительно будущего человечества, некоторые из них, на м...

Вкусные рецепты: супЪ, Закуска овощная - вариант !

супЪна 2,5 литра воды сварить две куриные грудки. как куриный бульон сварится грудки порезать кусочк...

Период овуляции – самый благоприятный для зачатия

В современном мире наблюдается такая тенденция, что женщины стараются перенести беременность на боле...

Как правильно заказать создание сайта

И так, Вы поняли, что Ваш бизнес без сайта далеко не продвинется, да и знакомые советуют  "Сделай са...

Вкусные рецепты: Тыква с медом и орехами, Салат из

Тыква с медом и орехамиС лимона снять цедру, выжать сок. Тыкву натереть на терке, заправить медом и ...



Новости развития информационнного портала:

Наш портал является ресурсом, который включает в себя широкий список информативных и отличных статей. Абсолютно каждый гость найдет для себя что-нибудь полезное. Модернизированный дизайн позволяет вам быстро находить требуемую информацию. Самые разнообразные тематические статьи дают возможность вам совершенствоваться в той или иной сфере. Быть более начитанным и грамотным. Современный дизайн сайта позволяет просматривать статьи на всех существующих планшетах. Теперь найти подходящую информацию стало совершенно легко.

Мы собрали для вас информативные и отличные статьи. На нашем портале вы найдете ответы на интересующие вас вопросы. Стандартная система поиска позволяет вам стремительно отыскать нужную информацию. Адаптированный дизайн позволяет вам просматривать информацию на абсолютно любых электронных устройствах. Теперь, поиск необходимой информации будет занимать у вас секунды.