Создание формы подбора для документа



В данной статье речь пойдет о создании формы подбора Номенклатуры, открываемой из формы документа для подбора необходимых позиций. Форма будет создана на основе общих форм и будет состоять из трех списков. Первый список будет отображать дерево значений номенклатуры, второй - непосредственно список номенклатуры, а в третьем будут отображаться выбранные значения. Для начала зайдем в документ, создадим кнопку "Подбор" и команду на кнопку. Теперь добавим действие на эту команду в котором пропишем код, открывающий форму подбора: &НаКлиенте
Процедура Подбор(Команда)
ОткрытьФорму("ОбщаяФорма. ФормаПодбора");
КонецПроцедуры
Далее закрываем форму документа (к ней мы вернемся чуть позже) и создаем новую общую форму "ФормаПодбора":

Далее добавляем таблицу на форму и реквизит к таблице. Тип данных реквизита будет "ДинамическийСписок". В свойствах реквизита в разделе Объект поставим галочку - "Произвольный запрос" и нажмем на ссылку Настройка списка: В появившейся форме нам необходимо будет написать запрос который будет отображаться в таблице "Дерево". Текст запроса будет выглядеть так: ВЫБРАТЬ
Номенклатура. Наименование КАК Группа
ИЗ
Справочник. Номенклатура КАК Номенклатура
ГДЕ
Номенклатура. ЭтоГруппа Теперь нужно немного изменить настройки для таблицы Дерево, точнее изменить кое какие свойства отображения нашего древовидного списка: 1. Установим галочку на свойство ТолькоПросмотр 2. Установим галочку на свойство РежимВыбора 3. ПоложениеКоманднойПанели - Нет 4. Отображение - Дерево 5. Режим выделения - Одиночный 6. Начальное отображение дерева - Раскрывать верхний уровень 7. Выбор групп и элементов - Группы 8. РазрешитьВыборКорня - Галочка Посмотрим что у нас получилось:

Неплохо. Следующим шагом будет создание таблицы где будет отображаться сама номенклатура. Создадим на форме еще отдну таблицу Список и добавим реквизит с таким же названием. Как и в случае с реквизитом Дерево повторяем те же манипуляции, т. е. тип - ДинамическийСписок, произвольный запрос - Да. Открываем форму редактирования запроса. Тут придется написать запрос чуточку сложнее (подробности можно посмотреть в конструкторе запросов): ВЫБРАТЬ
ЦеныСрезПоследних. Цена,
НоменклатураСписок. Код,
НоменклатураСписок. Ссылка
ИЗ
Справочник. Номенклатура КАК НоменклатураСписок
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений. Цены. СрезПоследних КАК ЦеныСрезПоследних
ПО НоменклатураСписок. Ссылка = ЦеныСрезПоследних. Номенклатура. Ссылка
ГДЕ
НоменклатураСписок. Родитель. Ссылка В(&Группа)
СГРУППИРОВАТЬ ПО
ЦеныСрезПоследних. Цена,
НоменклатураСписок. Код,
НоменклатураСписок. Ссылка Плюс нужно создать событие формы ПриСозданииНаСервере и прописать в нем наш фильтр "Группа": &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Список. Параметры. УстановитьЗначениеПараметра("Группа", Группа);
КонецПроцедуры Форма почти готова. Осталось связать наши таблицы: Дерево и Список. Для этого нужно будет создать еще несколько событий для таблицы Дерево: &НаКлиенте
Процедура ОбновитьСписок()
Список. Параметры. УстановитьЗначениеПараметра("Группа", Группа);
КонецПроцедуры

&НаКлиенте
Процедура ДеревоВыборЗначения(Элемент, Значение, СтандартнаяОбработка)
Группа = Значение;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
Группа = ВыбранноеЗначение;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоПередРазворачиванием(Элемент, Строка, Отказ)
Группа = Строка;
ОбновитьСписок();
КонецПроцедуры &НаКлиенте
Процедура ДеревоПередСворачиванием(Элемент, Строка, Отказ)
Группа = Строка;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоПриСменеТекущегоРодителя(Элемент)
Группа = Элемент. Родитель;
ОбновитьСписок();
КонецПроцедуры Наша форма почти готова: Ну и наконец добавим третий список (тип данных - ТаблицаЗначений), в который добавим 2 колонки - Номенклатура и Цена: а в таблице "Список" добавим событие "Выбор": &НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)

ТекущаяСтрока = Элемент. ТекущиеДанные;
НоваяСтрока = Отобранные. Добавить();
НоваяСтрока. Номенклатура = ТекущаяСтрока. Ссылка;
НоваяСтрока. Цена = ТекущаяСтрока. Цена;

КонецПроцедуры Теперь необходимо чтобы эта форма возвращала отобранные значения, обратно в форму документа. Для этого создадим новую кнопку "ОК" и создадим новую команду с таким же названием. Событие будет выглядеть так: &НаКлиенте
Процедура ОК(Команда)
Закрыть(ЗаписатьВХранилище());
КонецПроцедуры
а функция ЗаписатьВХранилище будет такая: &НаСервере
Функция ЗаписатьВХранилище()
Возврат ПоместитьВоВременноеХранилище(Отобранные. Выгрузить());
КонецФункции
Откроем опять форму нашего документа и исправим процедуру Подбор, добавив процедуру получения данных из временного хранилища: &НаСервере
Процедура ПолучитьЗапасыИзХранилища(АдресВХранилище)

ВременнаяТаблица = ПолучитьИзВременногоХранилища(АдресВХранилище);

Для Каждого ЗагружаемаяСтрока Из ВременнаяТаблица Цикл
СтрокаТЧ = Объект["Товар"]. Добавить();
СтрокаТЧ. Номенклатура = ЗагружаемаяСтрока. Номенклатура;
СтрокаТЧ. Цена = ЗагружаемаяСтрока. Цена;
КонецЦикла;

КонецПроцедуры
&НаКлиенте
Процедура Подбор(Команда)

ФормаПодбора = ПолучитьФорму("ОбщаяФорма. ФормаПодбора");
АдресВХранилище = ФормаПодбора. ОткрытьМодально();
Если ЗначениеЗаполнено(АдресВХранилище) Тогда
ПолучитьЗапасыИзХранилища(АдресВХранилище);
КонецЕсли;

КонецПроцедуры Наконец наша форма подбора готова: Источник материала
23:35 24.03.2017



Отзывы и комментарии
Ваше имя (псевдоним):
Проверка на спам:

Введите символы с картинки:



Зачем нужен копирайтинг?

Зачем нужен копирайтинг?

Копирайтер – это человек, создающий рекламные, продающие тексты. 20 лет назад никто и представить себе не мог, что будет такая профессия, без которой ни один уважающий себя сайт не сможет почувствоват...
Как сделать так, дабы дамы на сайтах знакомств самолично на вас бросались?

Как сделать так, дабы дамы на сайтах знакомств самол...

Очень многие из парней хотя бы раз, собирались знакомиться на дэйтинг порталах. Кое кто терпел "поражение", некоторые парни гордились их бешеной любовью женщин, а кто-то вообще развлекался м...
Учим английский? За год с нуля и до IELTS

Учим английский? За год с нуля и до IELTS

Изучение английского! Для многих наших сограждан это настоящая пытка! С какой ненавистью они открывают опостылевший учебник и с каким облегчением захлопывают его, когда время занятия заканчивается! Ка...
Как провести качественный ремонт в квартире своими руками?

Как провести качественный ремонт в квартире своими р...

Косметический квартирный ремонт нужно начинать с демонтажных действий. Убираем древние обои, устаревшие полы, ламинат или ковролин, покрытия на потолке, плитку в ванной и другое. На пол в квартире мож...
В чем феномен Владимира Высоцкого?

В чем феномен Владимира Высоцкого?

25 июля 1980 года Марина Влади проснулась в четыре утра. На подушке кроваво-багряное пятно — раздавила огромного комара. Тянется время, звонит телефон, в трубке ледяной голос: «В...
Как приготовить еврейский свадебный пирог? Волшебная сила традиций

Как приготовить еврейский свадебный пирог? Волшебная...

В жизни практически каждого есть человек, который помог научиться готовить. Мама, бабушка, подруга. Есть кого вспомнить с благодарностью за удачные советы и рецепты. В моей жизни была сотрудница, кото...
Читаемые

Мир жучков и шпионских штучек

Последние годы были отмечены значимым улучшением техники для шпионажа. Потребители таковых разработо...

Как сохранить 90% урожая фруктов? Арбузы, дыни, ви

Хотите лакомиться в новогоднюю ночь собственноручно выращенным арбузом? А виноградом? А дыней? Восто...

Российское дворянство. За какие заслуги можно было

В Европе титул барона известен со средневековья, хорошо его знали и на Руси, так как еще княжеские д...

Без ржавчины

Металлические входные двери с порошковым покрытием считаются довольно надежными и устойчивыми, но во...

Туры в Египет из Тулы

Таинственный Египет является одним из самых притягательных направлений российского рынка туризма. Ег...

Преимущества современных паровых кабин

Параллельно с уже привычными гидромассажными душевыми кабинами в магазинах сантехнического оборудова...

Вкусные рецепты: пирог Творожные Облака(может и ва

пирог Творожные Облака(может и вариант)Желтки отделить от белков.Белки взбить с пол нормы сахаром до...

Предлагаем познакомиться с новой услугой аренды

Пока не убедишься лично, ни за что не поверишь – такова уж природа человека. И это нормально, особен...

Как хозяйке обхитрить кризис? Хитрим с уксусом. Ча

На дворе лето, и вот потянулись мы все на воздух. Кто поработать до ломоты спины, кто отдохнуть. А в...

Морозильные лари

Морозильные лари - это морозильники горизонтального типа, которые применяются для заморозки и хранен...



О портале:

Наш портал является ресурсом, который включает в себя широкий список информативных и отличных статей. Абсолютно каждый гость найдет для себя что-нибудь полезное. Модернизированный дизайн позволяет вам быстро находить требуемую информацию. Самые разнообразные тематические статьи дают возможность вам совершенствоваться в той или иной сфере. Быть более начитанным и грамотным. Современный дизайн сайта позволяет просматривать статьи на всех существующих планшетах. Теперь найти подходящую информацию стало совершенно легко.

Мы собрали для вас информативные и отличные статьи. На нашем портале вы найдете ответы на интересующие вас вопросы. Стандартная система поиска позволяет вам стремительно отыскать нужную информацию. Адаптированный дизайн позволяет вам просматривать информацию на абсолютно любых электронных устройствах. Теперь, поиск необходимой информации будет занимать у вас секунды.