Создание формы подбора для документа



В данной статье речь пойдет о создании формы подбора Номенклатуры, открываемой из формы документа для подбора необходимых позиций. Форма будет создана на основе общих форм и будет состоять из трех списков. Первый список будет отображать дерево значений номенклатуры, второй - непосредственно список номенклатуры, а в третьем будут отображаться выбранные значения. Для начала зайдем в документ, создадим кнопку "Подбор" и команду на кнопку. Теперь добавим действие на эту команду в котором пропишем код, открывающий форму подбора: &НаКлиенте
Процедура Подбор(Команда)
ОткрытьФорму("ОбщаяФорма. ФормаПодбора");
КонецПроцедуры
Далее закрываем форму документа (к ней мы вернемся чуть позже) и создаем новую общую форму "ФормаПодбора":

Далее добавляем таблицу на форму и реквизит к таблице. Тип данных реквизита будет "ДинамическийСписок". В свойствах реквизита в разделе Объект поставим галочку - "Произвольный запрос" и нажмем на ссылку Настройка списка: В появившейся форме нам необходимо будет написать запрос который будет отображаться в таблице "Дерево". Текст запроса будет выглядеть так: ВЫБРАТЬ
Номенклатура. Наименование КАК Группа
ИЗ
Справочник. Номенклатура КАК Номенклатура
ГДЕ
Номенклатура. ЭтоГруппа Теперь нужно немного изменить настройки для таблицы Дерево, точнее изменить кое какие свойства отображения нашего древовидного списка: 1. Установим галочку на свойство ТолькоПросмотр 2. Установим галочку на свойство РежимВыбора 3. ПоложениеКоманднойПанели - Нет 4. Отображение - Дерево 5. Режим выделения - Одиночный 6. Начальное отображение дерева - Раскрывать верхний уровень 7. Выбор групп и элементов - Группы 8. РазрешитьВыборКорня - Галочка Посмотрим что у нас получилось:

Неплохо. Следующим шагом будет создание таблицы где будет отображаться сама номенклатура. Создадим на форме еще отдну таблицу Список и добавим реквизит с таким же названием. Как и в случае с реквизитом Дерево повторяем те же манипуляции, т. е. тип - ДинамическийСписок, произвольный запрос - Да. Открываем форму редактирования запроса. Тут придется написать запрос чуточку сложнее (подробности можно посмотреть в конструкторе запросов): ВЫБРАТЬ
ЦеныСрезПоследних. Цена,
НоменклатураСписок. Код,
НоменклатураСписок. Ссылка
ИЗ
Справочник. Номенклатура КАК НоменклатураСписок
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений. Цены. СрезПоследних КАК ЦеныСрезПоследних
ПО НоменклатураСписок. Ссылка = ЦеныСрезПоследних. Номенклатура. Ссылка
ГДЕ
НоменклатураСписок. Родитель. Ссылка В(&Группа)
СГРУППИРОВАТЬ ПО
ЦеныСрезПоследних. Цена,
НоменклатураСписок. Код,
НоменклатураСписок. Ссылка Плюс нужно создать событие формы ПриСозданииНаСервере и прописать в нем наш фильтр "Группа": &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Список. Параметры. УстановитьЗначениеПараметра("Группа", Группа);
КонецПроцедуры Форма почти готова. Осталось связать наши таблицы: Дерево и Список. Для этого нужно будет создать еще несколько событий для таблицы Дерево: &НаКлиенте
Процедура ОбновитьСписок()
Список. Параметры. УстановитьЗначениеПараметра("Группа", Группа);
КонецПроцедуры

&НаКлиенте
Процедура ДеревоВыборЗначения(Элемент, Значение, СтандартнаяОбработка)
Группа = Значение;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
Группа = ВыбранноеЗначение;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоПередРазворачиванием(Элемент, Строка, Отказ)
Группа = Строка;
ОбновитьСписок();
КонецПроцедуры &НаКлиенте
Процедура ДеревоПередСворачиванием(Элемент, Строка, Отказ)
Группа = Строка;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоПриСменеТекущегоРодителя(Элемент)
Группа = Элемент. Родитель;
ОбновитьСписок();
КонецПроцедуры Наша форма почти готова: Ну и наконец добавим третий список (тип данных - ТаблицаЗначений), в который добавим 2 колонки - Номенклатура и Цена: а в таблице "Список" добавим событие "Выбор": &НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)

ТекущаяСтрока = Элемент. ТекущиеДанные;
НоваяСтрока = Отобранные. Добавить();
НоваяСтрока. Номенклатура = ТекущаяСтрока. Ссылка;
НоваяСтрока. Цена = ТекущаяСтрока. Цена;

КонецПроцедуры Теперь необходимо чтобы эта форма возвращала отобранные значения, обратно в форму документа. Для этого создадим новую кнопку "ОК" и создадим новую команду с таким же названием. Событие будет выглядеть так: &НаКлиенте
Процедура ОК(Команда)
Закрыть(ЗаписатьВХранилище());
КонецПроцедуры
а функция ЗаписатьВХранилище будет такая: &НаСервере
Функция ЗаписатьВХранилище()
Возврат ПоместитьВоВременноеХранилище(Отобранные. Выгрузить());
КонецФункции
Откроем опять форму нашего документа и исправим процедуру Подбор, добавив процедуру получения данных из временного хранилища: &НаСервере
Процедура ПолучитьЗапасыИзХранилища(АдресВХранилище)

ВременнаяТаблица = ПолучитьИзВременногоХранилища(АдресВХранилище);

Для Каждого ЗагружаемаяСтрока Из ВременнаяТаблица Цикл
СтрокаТЧ = Объект["Товар"]. Добавить();
СтрокаТЧ. Номенклатура = ЗагружаемаяСтрока. Номенклатура;
СтрокаТЧ. Цена = ЗагружаемаяСтрока. Цена;
КонецЦикла;

КонецПроцедуры
&НаКлиенте
Процедура Подбор(Команда)

ФормаПодбора = ПолучитьФорму("ОбщаяФорма. ФормаПодбора");
АдресВХранилище = ФормаПодбора. ОткрытьМодально();
Если ЗначениеЗаполнено(АдресВХранилище) Тогда
ПолучитьЗапасыИзХранилища(АдресВХранилище);
КонецЕсли;

КонецПроцедуры Наконец наша форма подбора готова: Источник материала

Автор статьи: неизвестный | Дата публикации: 23:35 24.03.2017 Okayinfo.Ru




Отзывы и комментарии
Ваше имя (псевдоним):
Проверка на спам:

Введите символы с картинки:



Отправляйтесь в автобусные туры по Европе

Отправляйтесь в автобусные туры по Европе


Побывать в одну поездку в нескольких странах, увидеть достопримечательности множества старинных европейских городов, познакомиться с укладом жизни разных народов - все это позволяют познать автобу...


Вкусные рецепты: Корзиночки с шоколадным наполнителем "Пойманный в сети"., Мятно-шоколадный бисквит, Пирожное БУШЕ по Госту + бонус для Наташи (рулетка 78)

Вкусные рецепты: Корзиночки с шоколадным напо...


Корзиночки с шоколадным наполнителем "Пойманный в сети".В подходящей посуде взбейте венчиком размягчённое сливочное масло, яйца, ванильный сахар и сахарный песок. Просейте в смесь какао и взбейте. Под...


Самые популярные курорты Краснодарского побережья 2015 года

Самые популярные курорты Краснодарского побер...


Нереальный   рост доллара к рублю    значительно     повлияет     на  стоимость    заграничных    ту...


Линии на ладони

Линии на ладони


Большинству специалистов в области хиромантии, астрологии, графологии приходится отвечать на вопросы, касающиеся секса и тех качеств человека, которые могут способствовать, либо препятствовать романти...


Лена (быль)

Лена (быль)


В этой истории нет ни грамма вымысла. Мне тогда исполнилось сорок. Был я цветущим капитаном второго ранга, то и дело бросающим жаждущие взгляды на женские прелести. Недаром некоторые дамы, с которыми ...


Какие логопедические проблемы бывают у детей?

Какие логопедические проблемы бывают у детей?


Речь — это высшая функция. Отсутствие речи может привести к необратимым нарушениям в психическом и интеллектуальном развитии ребенка. В то же время излишнее стимулирование не всегда об...


Популярное

Как изменить свою жизнь? – секреты успешных людей.

Каждый человек во вселенной желает быть успешным и счастливым, иметь много денег, хорошие отношения и прекрасное самочувствие. Но, к сожалению не все понимают, как наладить свою судьбу и исправить сво...

Вкусные рецепты: Рыба на Кленовой дощечке с Шалфее

Рыба на Кленовой дощечке с Шалфеем и Креветками ! ! !Берём филе рыбы с шкурой и режем на порционные куски,чистим креветки и удаляем кишку,хвостики оставляем! Смешиваем: Соль,сахар,паприку,чёрный перец...

Цветовой интерьер кухни

Как мы уже писали, дизайн интерьера кухни наибольшим образом должен соответствовать вашему жизненному укладу и характеру. Рассмотрим вопрос создание цветового интерьера кухни. Для оформления любого пр...

антикризисные концепции бизнеса

Мне хотелось бы представить Вашему вниманию антикризисные концепции бизнеса, которые расскажут вам, как вести бизнес в момент кризиса и как заработать на нем. Сейчас во всем мире кризис, кто об этом н...

Какие логопедические проблемы бывают у детей?

Речь — это высшая функция. Отсутствие речи может привести к необратимым нарушениям в психическом и интеллектуальном развитии ребенка. В то же время излишнее стимулирование не всегда об...

Нужна ли молодость любой ценой?

Мы хотим оставаться красивыми и выглядеть молодо, несмотря на возраст. Придерживаемся диет, покупаем косметику и даже ложимся под нож хирурга. Это нормально, пока не становится навязчивой идеей. Ведь ...

Устройство стиральных машин. Поломки стиральных ма

Ваша стиралка  -  достаточно сложное устройство, включающее в себя: гидравлику,  механику,  пневматическую систему,  электрику  и  микроэлектрические элементы,  ...

Индукционная печь

Индукционные печи – это установки, в которых применяется индукционный нагрев для плавки металлов(или других материалов). Индукционные печи используются не только на огромных заводах, но и на маленьких...

Вкусные рецепты: Селедка под шубой, Капустница, Зе

Селедка под шубойселедку мелко нарезаем кубиком, картофель, свеклу, яйцо, натираем на крупной терке. Часть свеклы нарезаем тонкими кружочками. Лук нарезаем кубиком и ошпариваем кипятком, для того что ...

Астма – «красиво болеть», или все-таки лечить?

Бронхиальная астма в современном мире перестала быть сколько-нибудь редким или непривычным заболеванием. Если посмотреть любой фильм, снятый в развитой стране (США, Европа), то среди персонажей попа...

Развивая портал:

Наш портал является ресурсом, который включает в себя широкий список информативных и отличных статей. Абсолютно каждый гость найдет для себя что-нибудь полезное. Модернизированный дизайн позволяет вам быстро находить требуемую информацию. Самые разнообразные тематические статьи дают возможность вам совершенствоваться в той или иной сфере. Быть более начитанным и грамотным. Современный дизайн сайта позволяет просматривать статьи на всех существующих планшетах. Теперь найти подходящую информацию стало совершенно легко.

Мы собрали для вас информативные и отличные статьи. На нашем портале вы найдете ответы на интересующие вас вопросы. Стандартная система поиска позволяет вам стремительно отыскать нужную информацию. Адаптированный дизайн позволяет вам просматривать информацию на абсолютно любых электронных устройствах. Теперь, поиск необходимой информации будет занимать у вас секунды.